Update des Forums... (Update...) (1 Betrachter)

Betrachter - Thema (Registriert: 0, Gäste: 1)

Admin2

Administrator
Startbeitrag
Mitglied seit
1 Juli 2007
Beiträge
3.465
Bewertungen
8.565
Hallo Zusammen,

die Forensoftware und einige andere Software drumherum wurde, wie einige bereits bemerkten, erneuert.

Die erste Änderung die euch auffallen wird ist dass gelesene Threads und Beiträge nun explizit pro User in der Datenbank gespeichert werden und somit früher bereits gelesenes als nicht gelesen dargestellt wird.
Abonnierte Themen werden auch als ungelesen dargestellt. Hier muss man gegebenenfalls altes aussortieren.

UpDate:

Ich habe die alte Version der Speicherung gelesener Inhalte, in Form von Cookies auf dem jeweiligen Client, wieder aktiviert.
 
Zuletzt bearbeitet:

0zymandias

StarVIP Nutzer*in
Mitglied seit
31 Juli 2012
Beiträge
7.457
Bewertungen
16.095
AW: Update des Forums...

Danke für die Ostermontagsarbeit! :icon_daumen:
 
G

Gast1

Gast
AW: Update des Forums...

Mir ist Folgendes aufgefallen:

1. Schreibe ich einen neuen Beitrag in einem Thread, den ich abonniert habe, erscheint dieser Thread nach Erstellen des neuen Beitrags nicht mehr im Kontrollzentrum in der Liste der "Aktualisierten Themen". Dies habe ich bei einem Thread im OT-Bereich beobachtet.

2. Antworte ich auf einen Thread, den ich nicht abonniert hatte/in dem ich bisher nicht geschrieben hatte, erscheint dieser Thread nicht im Kontrollzentrum in der Liste der "Aktualisierten Themen", und er erscheint auch nicht in der Liste der Threads, die erscheint, wenn ich auf den Link "Neue Beiträge" klicke. Dieses Verhalten habe ich in Bezug auf einen Thread beobachtet, der heute im Hilfebereich erstellt worden ist.

Nachtrag:

3. Antworte ich auf einen Thread, den ich nicht abonniert hatte/in dem ich bisher nicht geschrieben hatte, erscheint dieser Thread nicht im Kontrollzentrum in der Liste der "Aktualisierten Themen", und er erscheint auch nicht in der Liste der Threads, die erscheint, wenn ich auf den Link "Neue Beiträge" klicke, und (neu:) er erscheint auch nicht im Kontrollzentrum in der Liste der "Aktualisierten Themen", nachdem ein anderer User einen neuen Beitrag in diesen Thread geschrieben hat. Dieses Verhalten habe ich in Bezug auf einen Thread beobachtet, der heute im Hilfebereich erstellt worden ist.

Ist dieses Verhalten so beabsichtigt?

Ich finde das Verhalten eher störend, weil ich - wenn ich einen Thread, in dem ich einen neuen oder ersten Beitrag erstellt hatte, noch einmal aufrufen möchte um z.B. an meinem neuesten oder ersten Beitrag in diesem Thread etwas zu ändern - den entsprechenden Thread nicht mehr im Kontrollzentrum in der Liste der "Aktualisierten Themen" finde. Ich muss stattdessen auf den "Start"-Link klicken und den Thread im entsprechenden Unterforum suchen und aufrufen.
 

Admin2

Administrator
Startbeitrag
Mitglied seit
1 Juli 2007
Beiträge
3.465
Bewertungen
8.565
AW: Update des Forums...

Mir ist Folgendes aufgefallen:

...
Ist dieses Verhalten so beabsichtigt?

Ich finde das Verhalten eher störend, weil ich - wenn ich einen Thread, in dem ich einen neuen oder ersten Beitrag erstellt hatte, noch einmal aufrufen möchte um z.B. an meinem neuesten oder ersten Beitrag in diesem Thread etwas zu ändern - den entsprechenden Thread nicht mehr im Kontrollzentrum in der Liste der "Aktualisierten Themen" finde. Ich muss stattdessen auf den "Start"-Link klicken und den Thread im entsprechenden Unterforum suchen und aufrufen.
Ich bin auch dabei das neue Verhalten zu beobachten. Ich habe allerdings vor dem Einloggen alle Forencookies gelöscht da die Informationen früher hier gespeichert wurden und sich störend auswirken könnten.

Dann habe ich in der Forenansicht ganz unten auf "Alle Foren als gelesen markieren" geklickt um massenweise vorhandenes veraltetes an Daten los zu werden und habe danach im Kontrollzentrum meine Abos ausgemistet.

Jetzt muss ich das erst mal eine Woche laufen lassen um genaueres sagen zu können.
 

DoppelPleite

VIP Nutzer*in
Mitglied seit
16 Dezember 2015
Beiträge
1.218
Bewertungen
1.728
AW: Update des Forums...

Also irgendwie hauen ein paar Sachen nicht mehr so hin... zB Dieser Tread hier "Update des Forums..." wir nicht in "Neue Beiträge" aufgeführt.

Ein von mir geschriebener Beitrag von 19:13 wird auch nicht in "Neue Beiträge" aufgeführt.

Was noch auffällt man kann x-beliebig oft auf "Neue Beiträge" klikken, vorher gabs eine Sperrzeit von 20 Sekunden.

Das Elo-Forum Icon oben in den Tab-Übersichten ist auch weg, nun so ein hellblaues Zeichen, aber das nicht so wichtig.

Nachtrag: In der Tat jetzt sind die 20Sekunden Sperrzeit wieder vorhanden.
 
Zuletzt bearbeitet:

Admin2

Administrator
Startbeitrag
Mitglied seit
1 Juli 2007
Beiträge
3.465
Bewertungen
8.565
AW: Update des Forums...

Nach meiner Beobachtung hat das mit den Browsercaches zutun.
Sind die aktualisiert funktioniert alles bis auf das von mir im Firstpost erwähnte wieder wie bisher. Die Caches kann man durch löschen selbst aktualisieren oder eben warten.

Unter Windows und auf mobilen Geräten sollte man auch mal Folgendes testen..
https://yandex-browser.de.uptodown.com/windows

Ich bin angenehm überrascht....
 
G

Gast1

Gast
AW: Update des Forums...

Nach meiner Beobachtung hat das mit den Browsercaches zutun.
Sind die aktualisiert funktioniert alles bis auf das von mir im Firstpost erwähnte wieder wie bisher. Die Caches kann man durch löschen selbst aktualisieren oder eben warten.
Ich habe vor ein paar Tagen, nach Einspielen des Forensoftware-Updates, den Cache und alle Cookies in meinem Browser gelöscht. Das Verhalten bezüglich der Nichtanzeige von Threads in der Liste der Neuen Beiträge, nachdem ich diese Threads geöffnet hatte, besteht aber weiterhin. Das Gleiche gilt für die Liste der aktualisierten Themen im Kontrollzentrum.

Auf meinem Rechner ist Linux-Debian 8.7 installiert, und ich benutzte den FF in Version 53.0

Ich werde mal Opera probieren, vielleicht ist das Verhalten in diesem Browser ja anders.
 
G

Gast1

Gast
AW: Update des Forums...

Update: Auch mit Opera ist auf meinem Rechner das Verhalten das Gleiche wie in meinem vorherigen Beitrag beschrieben. Opera in Version 44.0. Bevor ich mich ins Forum eingeloggt hatte, hatte ich in Opera alle Cookies und den Browsercache gelöscht.
 

Admin2

Administrator
Startbeitrag
Mitglied seit
1 Juli 2007
Beiträge
3.465
Bewertungen
8.565
AW: Update des Forums...

"Neue Beträge" werden "gecached" und das aktualisieren des Caches ist auf 10 Min eingestellt.
Will man seine neu erstellten Beiträge sofort nach den erstellen sehen muss man folgenden Link verwenden https://www.elo-forum.org/search.php?do=getnew (Heutige Beiträge).

Bei den abonnierten Themen muss zur Aktualisierung und sofortigen Anzeige neuer Themen im Benutzerkontrollzentrum unter "Aktualisierte Themen" auf https://www.elo-forum.org/subscription.php?do=viewsubscription&folderid=all "Alle abonierten Themen anzeigen" geklickt werden.

Die Intervalle der automatischen AnzeigeAktualisierungsFunktionen zu verkürzen oder gar zu deaktivieren würde ein Forum dieser Größe unbenutzbar machen da bei jedem neu erstellten Beitrag die Datenbank für alle registrierten Benutzer überprüft und entsprechend aktualisiert werden müsste.

Das aber hätte bei Foren dieser Größe den Effekt eines retweeteffekt ... How do i ddos myself :idea: :icon_evil:
 
G

Gelöschtes Mitglied 30227

Gast
AW: Update des Forums...

Ich hab seitdem immer einen Rattenschwanz an unnützen Beiträgen.
Die folgenden Themen wurden seit Ihrem letzten Besuch nicht aktualisiert, enthalten aber noch ungelesene Beiträge.
Obwohl ich alles in der vorigen Sitzung überflogen hatte. Die Software markiert nicht mehr die früher aufgerufenen Beiträge korrekt als gelesen.
Ich müßte umständlich immer auf die Hauptseite und
klicken.
Dies war früher anders und besser.
 
G

Gelöschtes Mitglied 30227

Gast
AW: Update des Forums...

Dann sollte es wie "Heutige Beiträge" im Menü aufgenommen werden, weil man es auch jede Sitzung klicken muss.
Strafanzeigen, Verfahrensrecht kann ja raus bzw. ausgetauscht werden.
 

Kerstin_K

StarVIP Nutzer*in
Mitglied seit
11 Juni 2006
Beiträge
21.734
Bewertungen
23.054
AW: Update des Forums...

Also ich kann aus den Neuerungen noch immer keinen Nutzen erkennen. Ganz im Geenteil.

Ich bin mal mit dem Handy, mal vom Laptop aus im Forum.

Wenn ich längere Beiträge schreiben will, mache ich das lieber am Laptop, kurte schreibe ich auch mal am Handy.

Mein Hauptproblem: Wenn ich einene Beitag am Handy gelesen habe und mich dann entschliesse, dazu was am Laptop zu schreiben, passiert das oft erst etwas später, weil ich zu Beispiel grade nicht zu Hause bin, zu faul bin, vom Sofa aufzustehen, den Laptop erstmal hochfahren muss oder sonstwas. Früher hat man den Thread dann meist noch unter neue Beiträge gesehen, auch, wenn sonst niemend in der zwishenzeit etwas dort geschrieben hatte. Jetzt verschwindet er und man muss den Thread erstmal über andere Ansichten wieder raussuchen. Ich finde das umständlich.

Ähnliches Poblem am Handy. Wenn ich etwas gelesen habe, verschwindet der Thread in neue Beiträge. Fällt mir nach einiger Zeit ein, das ich etwas dazu schreiben möchte und es hat sonst noch niemand etwas neues geschrieben, muss ich erstmal suchen. Da die nützlichen Links auf dem Handy auch nicht so vorhanden sind, echt umständlich. Könnte man vielleicht wenigstens den Menüpunkt heitige Beiträge noch oben in der Ansicht Neue Beiträge auf dem Handy unterbringen?
 

MissRuhrpott

Elo-User*in
Mitglied seit
14 Dezember 2013
Beiträge
563
Bewertungen
287
AW: Update des Forums...

Könnte man vielleicht wenigstens den Menüpunkt heitige Beiträge noch oben in der Ansicht Neue Beiträge auf dem Handy unterbringen?
Da war ich neugierig und hab's mal getestet.
Auf meinem Handy erscheint - nicht eingeloggt - 'heutige Beiträge'.
Diese Option wird zu 'neue Beiträge',wenn ich mich anmelde.
 

Kerstin_K

StarVIP Nutzer*in
Mitglied seit
11 Juni 2006
Beiträge
21.734
Bewertungen
23.054
AW: Update des Forums...

Ichhab aber wenig Lust, mich ewig ein- und auszuloggen.
 

Admin2

Administrator
Startbeitrag
Mitglied seit
1 Juli 2007
Beiträge
3.465
Bewertungen
8.565
AW: Update des Forums...

Brauchst du nimmer, die alte Version ist wieder aktiviert.
 

Kerstin_K

StarVIP Nutzer*in
Mitglied seit
11 Juni 2006
Beiträge
21.734
Bewertungen
23.054
Wurde das nach der heutigen Wartug wieder eingeschaltet?

Bitte nicht:icon_sad:
 
G

Gelöschtes Mitglied 30227

Gast
Es ist aber seit heute wieder so das ich den Rattenschwanz aller Beiträge wieder habe wie bei der Aktivierung.
 

Kerstin_K

StarVIP Nutzer*in
Mitglied seit
11 Juni 2006
Beiträge
21.734
Bewertungen
23.054
Eben. Und gelesene Threads versschwinden auch wieder.
 

Admin2

Administrator
Startbeitrag
Mitglied seit
1 Juli 2007
Beiträge
3.465
Bewertungen
8.565
Gelesene Threads werden nicht, wie das bei der "damaligen" Umstellung der Fall war, in der Datenbank gespeichert, sondern wie früher, mittels Cookies im jeweilig verwendeten Browser auf Clientseite. Was dort aber schief läuft kann ich dir nicht sagen.

Hast du also verschiedene Geräte (z.B. Laptop, Handy, Tablet) mit denen du das Forum besuchst werden auf dem jeweils verwendeten Gerät auch nur dort die Beiträge als gelesen markiert, die du auf dem jeweiligen Gerät gelesen hast.

So kommt es dass du Beträge die du mit dem Handy gelesen hast, auf dem Laptop erneut als ungelesen präsentiert bekommst etc.
 

Admin2

Administrator
Startbeitrag
Mitglied seit
1 Juli 2007
Beiträge
3.465
Bewertungen
8.565
Es ist aber seit heute wieder so das ich den Rattenschwanz aller Beiträge wieder habe wie bei der Aktivierung.
Das ist der Nachteil den ich damals durch die Umstellung zukünftig unterbinden wollte indem gelesene Beiträge anstatt als Cookie im Clientbrowser, lokal in der Datenbank vorhalten wollte.
Dagegen gab es "Widerstand", ich hatte keine Zeit für lange Erklärungen und hab die alte Einstellung wieder aktiviert.
Da es nun ein Upgrade der Forensoftware gab sind auch die Cookies verworfen worden und damit scheinbar auch die Gelesenen/Ungelesenen Sachen resettet.
 

Pfefferminz38

Elo-User*in
Mitglied seit
8 Juni 2017
Beiträge
167
Bewertungen
64
Es ist aber seit heute wieder so das ich den Rattenschwanz aller Beiträge wieder habe wie bei der Aktivierung.
Könnte das an einer Einstellung liegen?

Über jedem neuen Thema gibt es verschiedene "Reiter". Klick mal auf "Ansicht" und wähle "Linear Darstellung".
 
E

ExitUser

Gast
ich finde das sogar sehr vorteilhaft, weil ich innerhalb einer neuen "Session" wieder alle neuen Beiträge chronologisch habe und nicht nur die der letzten 24h. Und manchmal klick ich Threads auch nur kurz an, um mal kurz was zu gucken, ohne die jetzt ganz gelesen zu haben. Dann stört mich das auch nicht, dass die dann in der nächsten Session wieder als ungelesen auftauchen. Also ich finds besser als vorher.

Kerstin_K
Eben. Und gelesene Threads versschwinden auch wieder.
die verschwinden doch nicht. Die "verschwinden" nur "vordergründig" für die Threads, während derer man auf "aktualisieren" klickt und in dem Zeitraum zwischen dem letzten Off und dem neuesten On war oder ist. Oder so (?!). Jedenfalls wenn man dann wieder auf "neueste Beiträge" klickt, ist alles wieder da.
 
Oben Unten